Ticket #983 (closed defect: wontfix)

Opened 8 years ago

Last modified 5 years ago

IJ1 ships with more plugins

Reported by: bdezonia Owned by: bdezonia
Priority: major Milestone: imagej-2.0.0
Component: Build System Version:
Severity: serious Keywords:
Cc: dscho Blocked By:
Blocking: #1016

Description

The IJ1 Plugins menu has many more commands than IJ2. Add missing plugins to the IJ2 distribution. Test that they are working.

Change History

comment:1 Changed 7 years ago by curtis

  • Blocking 1010 added

comment:2 Changed 7 years ago by curtis

  • Blocking 1016 added; 1010 removed

comment:3 Changed 7 years ago by bdezonia

Chat log:

ctrueden
For 983, note that the issue is that IJ1 puts many macros and scripts in the menus. We will need a mechanism for that with IJ2.
ScriptPlugin, perhaps.
Or a MacroService and/or ScriptService.

11:41
bdezonia
Maybe not beta 1 then

11:42
ctrueden
Probably ScriptService, that discovers available scripts and constructs PluginInfos with ScriptPlugin, similar to how LegacyService does for LegacyPlugin.
I don't know how involved it would be. Maybe 1 day, maybe 1 week. Would have to research.

comment:4 Changed 7 years ago by bdezonia

  • Milestone changed from imagej-2.0.0-beta3 to imagej-2.0.0-beta4

comment:5 Changed 7 years ago by bdezonia

  • Milestone changed from imagej-2.0.0-beta4 to imagej-2.0.0

comment:6 Changed 7 years ago by bdezonia

  • Cc dscho added

dscho: this involves scripting some. feel free to chime in if you have anything to add.

comment:7 Changed 5 years ago by curtis

  • Status changed from new to closed
  • Resolution set to wontfix

We have evolved toward an ImageJ2 distribution that runs using the ImageJ1 user interface by default. So as things stand, the ImageJ2 UI probably does not need to support discovering and populating IJ1 scripts, as it now has a more long-term target with less of a focus on total backwards compatibility.

Last edited 5 years ago by curtis (previous) (diff)
Note: See TracTickets for help on using tickets.