Ticket #95 (closed feature: fixed)

Opened 9 years ago

Last modified 8 years ago

Modularity Infrastructure

Reported by: gharris Owned by: gharris
Priority: major Milestone: biweekly-2010: Jun-14 to Jun-25
Component: Plugin Framework Version:
Severity: non-issue Keywords:
Cc: Blocked By:
Blocking:

Description (last modified by gharris) (diff)

Modularity design for a "component-based system" - sometimes called module system, service platform, or component model, it addresses:

life cycle management, discovery, registration;
classloading, instantiation;
packaging/bundles, managing dependencies, access and visibility;
deployment and execution;

Recommendations for tools to use...

June 24, GBH and Rick L. presented example using OSGi and NetBeans Lookup API - see presentation here:  http://imagejdev.org/files/imagej/Modularity%20Presentation2.ppt

See research results at:

 http://imagejdev.org/gbh/arch/Modularity.html
and
 http://imagejdev.org/gbh/netbeans/

Change History

comment:1 Changed 9 years ago by gharris

  • Description modified (diff)

comment:2 Changed 9 years ago by gharris

  • Description modified (diff)
  • Milestone set to biweekly-2010: Jun-14 to Jun-25

comment:3 Changed 9 years ago by gharris

  • Status changed from new to assigned

comment:4 Changed 9 years ago by gharris

  • Status changed from assigned to accepted

comment:5 Changed 9 years ago by gharris

  • Description modified (diff)

comment:6 Changed 9 years ago by gharris

  • Status changed from accepted to closed
  • Type changed from defect to enhancement
  • Resolution set to fixed
  • Description modified (diff)
  • Severity changed from serious to non-issue

comment:7 Changed 8 years ago by curtis

This ticket seems like a duplicate of #15, and also #11.

comment:8 Changed 8 years ago by curtis

  • Type changed from enhancement to feature
Note: See TracTickets for help on using tickets.