Ticket #933 (closed defect: duplicate)

Opened 8 years ago

Last modified 7 years ago

Adding overlays can zoom inappropriately

Reported by: bdezonia Owned by: curtis
Priority: major Milestone: imagej2-b3-headless
Component: UI Framework Version:
Severity: serious Keywords:
Cc: Blocked By:
Blocking: #1185

Description

Open an image and zoom in a ways. Draw an overlay (like a line or a point). The display resizes quite large and the image is zoomed out.

Note that debugging I can see that AbstractDisplay thinks it's structure has changed (maybe the addition of an overlay is a structure change). This calls rebuild() which eventually calls sizeAppropriately() in the jhotdrawImageCanvas.

Either fix the sizing code or avoid the rebuild() depending upon what is the best approach.

Change History

comment:1 Changed 8 years ago by bdezonia

Note that it rebuilds the current window with dimensions = orig dims scaled by curr zoom factor. (This can get quite large for high zooms). And it draws the original image at 1:1 scale in the upper left corner of this window. Unless of course the scale * orig image dims is greater than desktop bound in which case the original image is even smaller in the corner.

Last edited 8 years ago by bdezonia (previous) (diff)

comment:2 Changed 8 years ago by bdezonia

Curtis, can you look at this one? Please assign back if you don't have time.

comment:3 Changed 8 years ago by bdezonia

  • Owner changed from bdezonia to curtis
  • Status changed from new to assigned

comment:4 Changed 8 years ago by bdezonia

Note after 8fedffcf4bfa0796aadec45140c7aad4ab47abaa that the window is no longer giant. But the image zooms from where it was to a small scale. The current zoom level should not be affected by drawing an overlay contained in the current window.

comment:5 Changed 8 years ago by curtis

  • Milestone changed from imagej-2.0-beta1 to imagej-2.0-beta2

comment:6 Changed 8 years ago by curtis

  • Blocking 1185 added

comment:7 Changed 8 years ago by curtis

See also #1189.

comment:8 Changed 7 years ago by curtis

  • Status changed from assigned to closed
  • Resolution set to duplicate

Duplicate of #1189.

Note: See TracTickets for help on using tickets.