Ticket #881 (closed defect: fixed)

Opened 8 years ago

Last modified 8 years ago

Dynamic plugins do not respect compiled initialization

Reported by: bdezonia Owned by: curtis
Priority: major Milestone: imagej2-b1-initial
Component: Plugin Framework Version:
Severity: serious Keywords:
Cc: Blocked By:
Blocking:

Description

If you make a DynamicPlugin and set the various @Parameter fields with compile time values the values are not respected. Not sure if this is by design. Please review and reassign as needed.

Example plugin:

package imagej.core.plugins.zoom;

import imagej.ext.plugin.DynamicPlugin;
import imagej.ext.plugin.Menu;
import imagej.ext.plugin.Parameter;
import imagej.ext.plugin.Plugin;

@Plugin(menu = { @Menu(label = "Image", mnemonic = 'i'),

@Menu(label = "Zoom", mnemonic = 'z'),
@Menu(label = "Fake...") })

public class ZoomFake extends DynamicPlugin {

@Parameter
private String s = "string";


@Parameter
private int i = 49;

@Parameter
private double d = Math.PI;

}

Change History

comment:1 Changed 8 years ago by curtis

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 3cd6179cd92be6a7f39a2739f4301b3c488eb610.

Note: See TracTickets for help on using tickets.