Ticket #876 (closed defect: fixed)

Opened 8 years ago

Last modified 8 years ago

Menu is disappearing

Reported by: bdezonia Owned by: curtis
Priority: major Milestone: imagej2-b1-initial
Component: UI Framework Version:
Severity: serious Keywords:
Cc: Blocked By:
Blocking:

Description

After opening an image the menu is no longer present. Clicking on the app bar restores it. But clicking back on the image makes it go away.

Assign as needed.

Change History

comment:1 Changed 8 years ago by curtis

  • Status changed from new to closed
  • Resolution set to fixed

(In [4431]) Scan for @EventHandler annotations recursively

Fixes #876. The bug was caused by the fact that AbstractSwingUI's
@EventHandler annotations were not being picked up, because it was an
abstract superclass of the actual Swing UI being used. So the
EventService.subscribe(Object) method did not find them before.

Note: See TracTickets for help on using tickets.