Ticket #851 (closed defect: duplicate)

Opened 7 years ago

Last modified 7 years ago

Drag and Drop unsupported image file results in exception

Reported by: bdezonia Owned by: bdezonia
Priority: major Milestone: imagej2-b2-bugfixes
Component: I/O Version:
Severity: serious Keywords:
Cc: Blocked By:
Blocking:

Description

Drag and drop has been implemented which allows one to drop a file from Finder onto the status area or toolbar area which will then be opened by IJ2.

(note this bug might have a duplicate ticket - I thought for sure I had reported it)

DnD works fairly well but if you drag some unsupported type (such as a PDF) you get an exception in the console window:

Caused by: loci.formats.UnknownFormatException: Unknown file format: /Users/bdezonia/Desktop/pay-employee-withholding.pdf

at loci.formats.ImageReader.getReader(ImageReader.java:179)
at loci.formats.ImageReader.setId(ImageReader.java:677)
at loci.formats.ReaderWrapper.setId(ReaderWrapper.java:488)
at loci.formats.ChannelFiller.setId(ChannelFiller.java:249)
at loci.formats.ReaderWrapper.setId(ReaderWrapper.java:488)
at loci.formats.ChannelSeparator.setId(ChannelSeparator.java:257)
at loci.formats.ReaderWrapper.setId(ReaderWrapper.java:488)
at net.imglib2.io.ImgOpener.createReader(ImgOpener.java:436)
at net.imglib2.io.ImgOpener.initializeReader(ImgOpener.java:494)
at net.imglib2.io.ImgOpener.openImg(ImgOpener.java:183)

Change History

comment:1 Changed 7 years ago by bdezonia

This bug should be addressed when ticket #860 is resolved. Suspending until then.

comment:2 Changed 7 years ago by bdezonia

  • Milestone changed from imagej-2.0-beta1 to imagej-2.0-beta2

comment:3 Changed 7 years ago by curtis

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #846.

comment:4 Changed 7 years ago by bdezonia

  • Milestone changed from imagej-2.0.0-beta3 to imagej-2.0.0-beta2
Note: See TracTickets for help on using tickets.