Ticket #846 (closed defect: fixed)

Opened 8 years ago

Last modified 6 years ago

Exception displayed when dropping unsupported file on application window

Reported by: bdezonia Owned by: bdezonia
Priority: major Milestone: imagej2-b7-ndim-data
Component: I/O Version:
Severity: serious Keywords:
Cc: Blocked By:
Blocking: #860

Description

Open IJ2. Open OS X Finder. Drag and drop a non-image file onto the the application. Exception displayed though no other side effects apparent.

Exception:

[ERROR] Exception
net.imglib2.io.ImgIOException: loci.formats.UnknownFormatException: Unknown file format: /Users/bdezonia/Desktop/pay-employee-withholding.pdf

at net.imglib2.io.ImgOpener.openImg(ImgOpener.java:189)
at net.imglib2.io.ImgOpener.openImg(ImgOpener.java:157)
at net.imglib2.io.ImgOpener.openImg(ImgOpener.java:116)
at imagej.io.plugins.OpenImage.run(OpenImage.java:89)
at imagej.ext.plugin.PluginModule.run(PluginModule.java:174)
at imagej.ext.module.ModuleRunner.run(ModuleRunner.java:148)
at imagej.ext.module.ModuleRunner.call(ModuleRunner.java:118)
at imagej.ext.module.ModuleRunner.call(ModuleRunner.java:1)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
at java.util.concurrent.FutureTask.run(FutureTask.java:138)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
at java.lang.Thread.run(Thread.java:680)

Caused by: loci.formats.UnknownFormatException: Unknown file format: /Users/bdezonia/Desktop/pay-employee-withholding.pdf

at loci.formats.ImageReader.getReader(ImageReader.java:179)
at loci.formats.ImageReader.setId(ImageReader.java:677)
at loci.formats.ReaderWrapper.setId(ReaderWrapper.java:488)
at loci.formats.ChannelFiller.setId(ChannelFiller.java:249)
at loci.formats.ReaderWrapper.setId(ReaderWrapper.java:488)
at loci.formats.ChannelSeparator.setId(ChannelSeparator.java:257)
at loci.formats.ReaderWrapper.setId(ReaderWrapper.java:488)
at net.imglib2.io.ImgOpener.createReader(ImgOpener.java:436)
at net.imglib2.io.ImgOpener.initializeReader(ImgOpener.java:494)
at net.imglib2.io.ImgOpener.openImg(ImgOpener.java:183)
... 12 more

[WARN ] Ignoring unsupported output: null

Change History

comment:1 Changed 8 years ago by bdezonia

  • Milestone changed from imagej-2.0-beta1 to imagej-2.0-beta2

This should be fixed when we redo drag and drop as sezpoz enabled droppers. No unsupported file should then get handled by any dropper. Moving to a later beta to verify behavior is fixed by drag/drop rewrite.

comment:2 Changed 7 years ago by curtis

  • Blocking 9, 11 added

comment:3 Changed 7 years ago by curtis

  • Blocking 860 added; 9, 11 removed

comment:4 Changed 7 years ago by bdezonia

  • Milestone changed from imagej-2.0.0-beta3 to imagej-2.0.0-beta4

comment:5 Changed 7 years ago by bdezonia

  • Milestone changed from imagej-2.0.0-beta4 to imagej-2.0.0-beta5

comment:6 Changed 6 years ago by curtis

  • Status changed from new to closed
  • Resolution set to fixed

In principle, this is fixed with the new drag-and-drop infrastructure. However, in practice SCIFIO often erroneously claims support for files and then throws an exception. But that bug is outside the scope of drag-and-drop specifically, so I am closing this ticket.

Note: See TracTickets for help on using tickets.