Ticket #826 (closed defect: duplicate)

Opened 7 years ago

Last modified 7 years ago

Crop does not always resize window

Reported by: bdezonia Owned by: curtis
Priority: major Milestone: imagej2-b3-headless
Component: Display API Version:
Severity: serious Keywords:
Cc: Blocked By:
Blocking: #1242

Description

Crop has recently been rewritten. When you do a crop sometimes the canvas does not resize to the new smaller dimensions. It looks like this is another display update/timing bug.

I have put a hack into CropImage that has detailed notes including different approaches for fixing. However until the display timing bugs are ironed out it might not make sense to tackle this yet.

Note that redoLayout() is getting called multiple times which can fix the canvas size issue. So open boats, draw overlay, and crop. If it does not resize correctly then draw a new overlay over image and the canvas resizes correctly.

Change History

comment:1 Changed 7 years ago by curtis

Fix waiting on ticket #828.

comment:2 Changed 7 years ago by curtis

  • Status changed from new to accepted

comment:3 Changed 7 years ago by bdezonia

Note: 11-1-11 - inside CropImage removed call to hack but left hack documentation in place in case it helps debug this issue.

comment:4 Changed 7 years ago by curtis

  • Milestone changed from imagej-2.0-beta1 to imagej-2.0-beta2

comment:5 Changed 7 years ago by curtis

  • Blocking 1242 added

comment:6 Changed 7 years ago by curtis

  • Status changed from accepted to closed
  • Resolution set to duplicate

Duplicate of #1101.

comment:7 Changed 7 years ago by curtis

  • Milestone changed from imagej-2.0.0-beta3 to imagej-2.0.0-beta4

comment:8 Changed 7 years ago by curtis

  • Milestone changed from imagej-2.0.0-beta4 to imagej-2.0.0-beta3
Note: See TracTickets for help on using tickets.