Ticket #789 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

PixelProbe IndexOutOfBoundsException with Multi-Channel image

Reported by: gharris Owned by: bdezonia
Priority: minor Milestone: imagej2-b1-initial
Component: Tools Version:
Severity: serious Keywords:
Cc: Blocked By:
Blocking:

Description

Opened multi-channel.ome.tiff sample image with IJ2 OpenFile...
when mouse-over the image, MsMovedEvent causes exception:

Caused by: java.lang.IndexOutOfBoundsException: Index: 3, Size: 3

at java.util.ArrayList.RangeCheck(ArrayList.java:547)
at java.util.ArrayList.get(ArrayList.java:322)
at net.imglib2.img.planar.PlanarImg.update(PlanarImg.java:134)

Change History

comment:1 Changed 7 years ago by bdezonia

  • Owner changed from gharris to bdezonia
  • Status changed from new to assigned

comment:2 Changed 7 years ago by bdezonia

  • Status changed from assigned to closed
  • Resolution set to fixed

comment:3 Changed 7 years ago by bdezonia

fixed in c1032df2337d62af446c9f67d5fe4252f634d03e

Note: See TracTickets for help on using tickets.