Ticket #781 (closed defect: wontfix)

Opened 8 years ago

Last modified 8 years ago

Window/Level broken

Reported by: afraser Owned by: curtis
Priority: major Milestone: imagej2-b1-initial
Component: Legacy Compatibility Version:
Severity: serious Keywords: refresh
Cc: Blocked By:
Blocking:

Description

This is filed under legacy but may be a display refresh problem.

Plugin does nothing at all to Clown and M51 Galaxy

On Boats and Bridge, the plugin appears to do nothing but there may just be a refresh problem since inverting the image twice reveals the expected changes.

On T1 Head Renderings the plugin doesn't appear to do anything, but if you scrub through Z the changes become visible.

See also #780.

tested on ff78f1f00c5069b267bd05ed9c5350c3100536f2

Change History

comment:1 Changed 8 years ago by curtis

  • Status changed from new to closed
  • Resolution set to wontfix

This is a GUI-driven plugin, not slated for support from IJ2. The issue is with plugin frames that have dynamic repaints (unsupported), rather than plugins which have a distinct conclusion to their execution, at which point we can resync (supported).

Rather, our goal is to reimplement these interactive plugins as IJ2 plugins. See Brightness/Contrast for an example.

Note: See TracTickets for help on using tickets.