Ticket #780 (closed defect: wontfix)

Opened 8 years ago

Last modified 8 years ago

Color Balance broken

Reported by: afraser Owned by: curtis
Priority: major Milestone: imagej2-b1-initial
Component: Legacy Compatibility Version:
Severity: serious Keywords: color balance
Cc: Blocked By:
Blocking:

Description (last modified by afraser) (diff)

I can't seem to make this plugin do anything. Period. Tested it on clown.jpg in Composite and Color modes.

Addendum: This could be a refresh problem since it actually appears to work on Boats, but isn't visible until I invert the image twice... for some reason the invert trick doesn't work for RGB images though.

tested with ff78f1f00c5069b267bd05ed9c5350c3100536f2

Change History

comment:1 Changed 8 years ago by afraser

  • Description modified (diff)

comment:2 Changed 8 years ago by afraser

  • Description modified (diff)

comment:3 Changed 8 years ago by curtis

  • Status changed from new to closed
  • Resolution set to wontfix

This is a GUI-driven plugin, not slated for support from IJ2. The issue is with plugin frames that have dynamic repaints (unsupported), rather than plugins which have a distinct conclusion to their execution, at which point we can resync (supported).

Rather, our goal is to reimplement these interactive plugins as IJ2 plugins. See Brightness/Contrast for an example.

Note: See TracTickets for help on using tickets.