Ticket #774 (closed defect: fixed)

Opened 8 years ago

Last modified 8 years ago

convert to 8-bit color broken

Reported by: afraser Owned by: bdezonia
Priority: critical Milestone: imagej2-b1-initial
Component: Legacy Compatibility Version:
Severity: critical Keywords: type, 8-bit color, LUT
Cc: Blocked By:
Blocking:

Description (last modified by afraser) (diff)

open clown.jpg
Image > type > 8-bit Color

2 Problems:
1) The display is duplicated and the command appears to be run on both displays.
2) The resultant image looks completely mangled, but it MAY just be that the LUT isn't getting set since it still shows a gray ramp.

(see also #765, #768 for LUT issues)

tested with ff78f1f00c5069b267bd05ed9c5350c3100536f2

Change History

comment:1 Changed 8 years ago by afraser

  • Severity changed from serious to critical

comment:2 Changed 8 years ago by afraser

  • Component changed from other to ij-legacy

comment:3 Changed 8 years ago by afraser

  • Description modified (diff)

comment:4 Changed 8 years ago by curtis

  • Owner changed from curtis to bdezonia
  • Status changed from new to assigned

This does appear to be two separate issues. The latter issue will probably go away when the LUT syncing is fixed (see #765, #768). The former issue, the window duplication, may have another root cause (see also #775 for a related bug there).

comment:5 Changed 8 years ago by curtis

Ticket #550 was closed as a duplicate of this bug, but there is some useful observation there.

Note that in IJ1, converting from a 3-channel 8-bit composite image to an 8-bit color image is not supported. However, under the hood, our 3-channel 8-bit composite images are stored in IJ1 as RGB color (i.e., 24-bit packed ints) when the Dataset#isRGBMerged() flag is set. In that case, the translation to 8-bit color via the legacy layer *should* work, preserving the LUT. To do otherwise is a bug.

comment:6 Changed 8 years ago by bdezonia

Duplicated window issue dealt with in 9ecb3078dc1f5da7f4ab7137cc32aa9148d00064

comment:7 Changed 8 years ago by bdezonia

  • Status changed from assigned to closed
  • Resolution set to fixed

Fixed with 76e40fc0e2c1465400c71f289c9cb731b2964928

Note: See TracTickets for help on using tickets.