Ticket #773 (closed defect: fixed)

Opened 8 years ago

Last modified 6 years ago

Reshaping via "Properties" sometimes crashes IJ display

Reported by: afraser Owned by: curtis
Priority: minor Milestone: imagej2-b7-ndim-data
Component: Legacy Compatibility Version:
Severity: serious Keywords: Properties, reshape, hyperstack
Cc: Blocked By:
Blocking: #1011

Description (last modified by afraser) (diff)

Open the Mitosis 5D stack
Image > Properties (Ctrl+Shift+P)
set Channels = 1
set Slices = 10
click OK

Sometimes a new image display will be created with the expected rearranged planes. Other times the existing display starts to flicker and closes (but not the whole app).

Expected behavior from IJ1 is for the existing display to be updated such that the channel slider goes away, and the Z slider then has 10 frames along which the channels are interleaved.

Note: the same issue is present when doing the same thing via
Image > HyperStacks > Stack to HyperStack

Change History

comment:1 Changed 8 years ago by afraser

  • Keywords reshape, hyperstack added; reshape removed
  • Description modified (diff)

comment:2 Changed 8 years ago by afraser

  • Summary changed from Reshaping via "Properties" sometimes crashes IJ to Reshaping via "Properties" sometimes crashes IJ display

comment:3 Changed 8 years ago by afraser

  • Component changed from other to ij-legacy

comment:4 Changed 8 years ago by bdezonia

Using 8fedffcf4bfa0796aadec45140c7aad4ab47abaa I get the following exception (LegacyPlugin line refs are off a little due to print statements on my machine but other classes' line refs are correct and ALL method names are correct).

[ERROR] ImageJ 1.x plugin threw exception
java.lang.IllegalArgumentException: Channel mismatch: 2 vs. 1

at imagej.legacy.translate.ColorTableHarmonizer.assignChannelMinMax(ColorTableHarmonizer.java:342)
at imagej.legacy.translate.ColorTableHarmonizer.updateDisplay(ColorTableHarmonizer.java:80)
at imagej.legacy.translate.Harmonizer.updateDisplay(Harmonizer.java:180)
at imagej.legacy.plugin.LegacyPlugin.updateDisplaysFromImagePluses(LegacyPlugin.java:281)
at imagej.legacy.plugin.LegacyPlugin.run(LegacyPlugin.java:161)
at imagej.ext.plugin.PluginModule.run(PluginModule.java:150)
at imagej.ext.module.ModuleRunner.run(ModuleRunner.java:148)
at imagej.ext.module.ModuleRunner.call(ModuleRunner.java:118)
at imagej.ext.module.ModuleRunner.call(ModuleRunner.java:1)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
at java.util.concurrent.FutureTask.run(FutureTask.java:138)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
at java.lang.Thread.run(Thread.java:680)

comment:5 Changed 7 years ago by curtis

  • Blocking 1011 added

comment:6 Changed 7 years ago by curtis

  • Milestone set to imagej-2.0-final

comment:7 Changed 7 years ago by curtis

  • Milestone changed from imagej-2.0.0 to imagej-2.0.0-beta4

comment:8 Changed 7 years ago by curtis

  • Milestone changed from imagej-2.0.0-beta4 to imagej-2.0.0-beta5

comment:9 Changed 6 years ago by bdezonia

I can't duplicate this using a version after beta 6 and before beta 7.

comment:10 Changed 6 years ago by bdezonia

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.