Ticket #767 (closed defect: wontfix)

Opened 8 years ago

Last modified 8 years ago

tif stack loads differently in IJ1 & 2

Reported by: afraser Owned by: curtis
Priority: major Milestone: imagej2-b1-initial
Component: Legacy Compatibility Version:
Severity: serious Keywords:
Cc: Blocked By:
Blocking:

Description

I'm not sure exactly what to file this under, but basically, I used IJ1 to convert the mitosis image hyperstack into a stack via Image > Hyperstacks > Hyperstack to stack. I then saved the file to tiff (attached).

When the attached file is opened in IJ1 I see what I expect, but IJ2 appears to magically turn the stack back into a hyperstack. Maybe I'm doing something silly, but this seems like a bug.

Attachments

mitosis.tif Download (32.7 MB) - added by afraser 8 years ago.
mitosis stack

Change History

Changed 8 years ago by afraser

mitosis stack

comment:1 Changed 8 years ago by curtis

  • Status changed from new to closed
  • Resolution set to wontfix

The issue is that when IJ1 saved the file, it still embedded the number of channels, frames and slices into the TIFF metadata. I am not sure how IJ1 knows to display the file as a regular stack rather than hyperstack, since there is no obvious metadata field declaring to do so.

However, I am not very worried about this problem. Too much information (e.g., discrete dimensional axes) is much less of an issue than too little (e.g., axes being mushed together). Users can always combine the axes together afterward using a restructuring plugin if desired.

Note: See TracTickets for help on using tickets.