Ticket #764 (closed defect: fixed)

Opened 8 years ago

Last modified 7 years ago

New image filled with wrong value

Reported by: afraser Owned by: bdezonia
Priority: major Milestone: imagej2-b1-initial
Component: Legacy Compatibility Version:
Severity: minor Keywords:
Cc: Blocked By:
Blocking:

Description

File > New (legacy)
type: 16 bit
fill with: white

Resultant image is filled with black.

ALSO:

File > New (legacy)
type: 32 bit
fill with: white OR black

Resultant image is filled with gray but the mouse probe reports a value of 0.0.

Change History

comment:1 Changed 7 years ago by curtis

  • Owner changed from curtis to bdezonia
  • Status changed from new to assigned

It looks like the 16-bit cases are fixed now.

However, there is still a problem with new 32-bit images. The color range is not syncing properly (or autoscaling is not respecting that range), because with either white or black, the data appears as gray.

comment:2 Changed 7 years ago by bdezonia

  • Status changed from assigned to closed
  • Resolution set to fixed

Tested with 6263f51f04d11eaba2fe1777ddfe7fabb5f03e10 and the data is always populated correctly. There is a noticeable lag between when the new image is originally populated and when its display values get set to the correct color. Debugging LegacyPlugin one can see that there is a long time spent waiting for the IJ1 new image plugin threads to terminate before synchronizing data. I'll hatch a separate ticket for that issue.

Note: See TracTickets for help on using tickets.