Ticket #684 (closed defect: fixed)

Opened 8 years ago

Last modified 8 years ago

Add data plugin can throw exception

Reported by: bdezonia Owned by: bdezonia
Priority: major Milestone: biweekly-2011: Jul-18 to Jul-29
Component: Display API Version:
Severity: serious Keywords:
Cc: Blocked By:
Blocking:

Description

Open Organ Of Corti
Run Add Data plugin
Choose Channel as the axis to add along
I specified size of 1 and position of 3
Exception thrown and display not updated

Caused by: java.lang.IndexOutOfBoundsException: Index: 4, Size: 4

at java.util.ArrayList.RangeCheck(ArrayList.java:547)
at java.util.ArrayList.get(ArrayList.java:322)
at imagej.display.AbstractDatasetView.updateLUTs(AbstractDatasetView.java:295)
at imagej.display.AbstractDatasetView.resetColorTables(AbstractDatasetView.java:152)
at imagej.display.AbstractDatasetView.rebuild(AbstractDatasetView.java:221)
at imagej.display.AbstractDisplayView$2.onEvent(AbstractDisplayView.java:175)
at imagej.display.AbstractDisplayView$2.onEvent(AbstractDisplayView.java:1)
at org.bushe.swing.event.ThreadSafeEventService.publish(ThreadSafeEventService.java:971)

Change History

comment:1 Changed 8 years ago by bdezonia

  • Status changed from new to closed
  • Resolution set to fixed

fixed in aca5f9a2e542eb17d633c081a430a365fe0d0882

Note: See TracTickets for help on using tickets.