Ticket #544 (closed defect: worksforme)

Opened 8 years ago

Last modified 8 years ago

Exception thrown on Dataset::delete()

Reported by: bdezonia Owned by: bdezonia
Priority: major Milestone: biweekly-2011: May-23 to Jun-03
Component: Data Model Version:
Severity: serious Keywords:
Cc: Blocked By:
Blocking:

Description

Open Blobs sample Image. Choose Image :: Rename. Now close image window. Window closes but exception thrown in log file.

[WARN ] Exception thrown by;EventService subscriber:imagej.legacy.LegacyImageMap$1@2353f67e. Subscriber class:class imagej.legacy.LegacyImageMap$1
org.bushe.swing.exception.SwingException: Exception handling event topic event class=imagej.data.event.DatasetDeletedEvent, event=imagej.data.event.DatasetDeletedEvent@258b678c, topic=null, eventObj=null
org.bushe.swing.exception.SwingException: Exception handling event topic event class=imagej.data.event.DatasetDeletedEvent, event=imagej.data.event.DatasetDeletedEvent@258b678c, topic=null, eventObj=null

at org.bushe.swing.event.ThreadSafeEventService.handleException(ThreadSafeEventService.java:2021)
at org.bushe.swing.event.ThreadSafeEventService.handleException(ThreadSafeEventService.java:2009)
at org.bushe.swing.event.ThreadSafeEventService.publish(ThreadSafeEventService.java:975)
at org.bushe.swing.event.SwingEventService.publish(SwingEventService.java:78)
at org.bushe.swing.event.ThreadSafeEventService.publish(ThreadSafeEventService.java:904)
at org.bushe.swing.event.EventBus.publish(EventBus.java:57)
at imagej.event.Events.publish(Events.java:52)
at imagej.data.Dataset.delete(Dataset.java:309)
at imagej.data.AbstractDataObject.decrementReferences(AbstractDataObject.java:58)
at imagej.display.AbstractDisplayView.dispose(AbstractDisplayView.java:115)
at imagej.ui.swing.display.SwingImageDisplay$1.windowClosed(SwingImageDisplay.java:102)
at java.awt.AWTEventMulticaster.windowClosed(AWTEventMulticaster.java:343)
at java.awt.AWTEventMulticaster.windowClosed(AWTEventMulticaster.java:342)
at java.awt.Window.processWindowEvent(Window.java:1868)
at javax.swing.JFrame.processWindowEvent(JFrame.java:274)
at java.awt.Window.processEvent(Window.java:1823)
at java.awt.Component.dispatchEventImpl(Component.java:4736)
at java.awt.Container.dispatchEventImpl(Container.java:2143)
at java.awt.Window.dispatchEventImpl(Window.java:2478)
at java.awt.Component.dispatchEvent(Component.java:4566)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:680)
at java.awt.EventQueue.access$000(EventQueue.java:86)
at java.awt.EventQueue$1.run(EventQueue.java:639)
at java.awt.EventQueue$1.run(EventQueue.java:637)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:98)
at java.awt.EventQueue$2.run(EventQueue.java:653)
at java.awt.EventQueue$2.run(EventQueue.java:651)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:650)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:201)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Caused by: java.util.ConcurrentModificationException

at java.util.WeakHashMap$HashIterator.nextEntry(WeakHashMap.java:762)
at java.util.WeakHashMap$KeyIterator.next(WeakHashMap.java:795)
at imagej.legacy.LegacyImageMap.unregisterDataset(LegacyImageMap.java:139)
at imagej.legacy.LegacyImageMap$1.onEvent(LegacyImageMap.java:165)
at imagej.legacy.LegacyImageMap$1.onEvent(LegacyImageMap.java:1)

Change History

comment:1 Changed 8 years ago by bdezonia

  • Status changed from new to closed
  • Resolution set to worksforme

Cannot duplicate with version 0a1002ec77ab2f2ee3da645b88791fcaed8305b7.

Note: See TracTickets for help on using tickets.