Ticket #539 (closed defect: fixed)

Opened 8 years ago

Last modified 8 years ago

For given file probe reports different pixels values between IJ1 & IJ2.

Reported by: bdezonia Owned by: bdezonia
Priority: major Milestone: biweekly-2011: May-23 to Jun-03
Component: Core Version:
Severity: serious Keywords:
Cc: Blocked By:
Blocking:

Description

The attached file displays differently in IJ1 & IJ2. At first I thought it was a display only issue but the two programs report different values using their probe tools over background areas. There is one loner cell near the upper right corner where you can see pixel values of 7-40 in IJ1 that range all the way to 255 in IJ2. ANother way to see the data sifference is to run the sharpen command on each one. the output images are very dissimilar.

Attachments

EL_ImageToProcess2.png Download (312.6 KB) - added by bdezonia 8 years ago.

Change History

Changed 8 years ago by bdezonia

comment:1 Changed 8 years ago by bdezonia

  • Component changed from ij-io to ij-core

Did more thorough analysis. As loaded from disk these images are the same.

Do a sharpen and they look completely different.

Do a revert in IJ2 and some of the pixel values go from low values (3-7) to high values (243-255). Again you can see this by probing the inside of the cell that is a loner near the upper right corner.

comment:2 Changed 8 years ago by bdezonia

Two bugs here? Sharpen broken and revert failing?

comment:3 Changed 8 years ago by bdezonia

This is indeed two bugs. I will open the sharpen issue as a different bug. It is related to convolution being different in IJ1 for different kinds of processors (byte/short/float). For the sake of this bug avoid using a convolution oriented data changers.

So this bug is trying to figure out why revert does not restore original pixel values in IJ2.

One can reproduce this issue by opening attached image in IJ2, using Process :: Math :: Set to change the pixel values to lets say 15. Then do a File :: Revert. The data is resoted to the screen correctly. But the probe is reporting the old values (15 everywhere).

comment:4 Changed 8 years ago by bdezonia

It looks like Probe needs to listen for Dataset events and reset its working variables when this happens.

comment:5 Changed 8 years ago by bdezonia

  • Status changed from new to closed
  • Resolution set to fixed

fixed in 7cadcce428524a961cebf8761f93af945100b73c

Note: See TracTickets for help on using tickets.