Ticket #500 (closed task: fixed)

Opened 9 years ago

Last modified 9 years ago

Rename RegionCursor

Reported by: bdezonia Owned by: bdezonia
Priority: major Milestone: biweekly-2011: May-09 to May-20
Component: ImgLib2 Version:
Severity: serious Keywords:
Cc: Blocked By:
Blocking:

Description

The OPS class RegionCursor does not conform to the Cursor interface. Neither does it conform to the Iterator interface. Maybe make it conform to one of them and rename the class. Or decide its interface is fine and find a better name for it (like RegionWalker).

Change History

comment:1 Changed 9 years ago by bdezonia

Renamed it to RegionIterator and made it conform to the Iterator interface. Even though it is a little uglier, performance improved by 20%.

comment:2 Changed 9 years ago by bdezonia

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.