Ticket #495 (closed defect: fixed)

Opened 8 years ago

Last modified 8 years ago

Tool cursors can get out of synch

Reported by: bdezonia Owned by: bdezonia
Priority: major Milestone: biweekly-2011: May-09 to May-20
Component: Tools Version:
Severity: serious Keywords:
Cc: Blocked By:
Blocking:

Description

Make a gradient image. Choose probe tool and cursor goes to cross. Make another gradient image. Cursor is now arrow over that image. Move over the original image it is correct. However in both windows probe results are shown. Unfortunately the arrow cursor position is inaccurate and what you are pointing at is different than what the probe tool reports. This is most apparent when inspecting a boundary on an 8 bit gradient image zoomed 100%.

Change History

comment:1 Changed 8 years ago by bdezonia

  • Owner changed from curtis to bdezonia
  • Status changed from new to assigned

comment:2 Changed 8 years ago by bdezonia

The description is not entirely clear. When hovering over the first image the cursor is always a cross and so you can see the correct data values. Over the other image it is always an arrow and the tip of the arrow does not point at the pixel being probed (it is off by a few pixels). So those data values as reported by the probe are wrong. The key issue is that the application is losing track of which cursor should be enforced (i.e. since the ProbeTool is active its cursor should also be).

comment:3 Changed 8 years ago by bdezonia

  • Status changed from assigned to closed
  • Resolution set to fixed
  • Milestone changed from imagej-2.0-alpha3 to biweekly-2011: May-09 to May-20
Note: See TracTickets for help on using tickets.