Ticket #493 (closed task: fixed)

Opened 8 years ago

Last modified 7 years ago

Test legacy plugins

Reported by: bdezonia Owned by: afraser
Priority: major Milestone: imagej2-b1-initial
Component: Legacy Compatibility Version:
Severity: serious Keywords:
Cc: Blocked By:
Blocking:

Description

Test legacy plugins for compatibility with IJ2. As needed create tickets detailing which IJ1 plugins need pure IJ2 replacements.

Change History

comment:1 Changed 8 years ago by bdezonia

This is an ongoing process ...

comment:2 Changed 8 years ago by bdezonia

  • Owner changed from bdezonia to afraser
  • Status changed from new to assigned

Adam, I believe you are working on this.

comment:3 Changed 8 years ago by bdezonia

BTW Adam, one thing to test is all the macros that are bundled in ij.jar. :(

comment:4 Changed 8 years ago by curtis

This is a big ticket, so please try to add a comment at least once per two-week milestone with a status update.

comment:5 Changed 8 years ago by afraser

Tested all sample images since some will need to be used for testing other plugins. Many displayed differently than the same sample in IJ1. Details are here:  https://spreadsheets.google.com/a/broadinstitute.org/spreadsheet/ccc?key=0ApOdW3lEv09MdDB4OU4xdHZkYlhPU2ZNaklDdWlQdWc&hl=en_US&pli=1#gid=0

Many filters have been tested as well as many basic commands like copy & paste.

One serious hinderance to this effort is that many actions are not able to be recorded as macros, so macros can't be used to reproduce a specific behavior. For now I've been describing the necessary actions in the above document... we've yet to see how well this will work when people get around to addressing these issues. Writing unit tests for all commands will be very tedious, but it has to be done eventually. It's a question of priorities. Do we want to identify our biggest bugs and address them ASAP, or do we want to slowly and methodically chug through them all?

comment:6 Changed 7 years ago by afraser

  • Status changed from assigned to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.