Ticket #424 (closed enhancement: fixed)

Opened 9 years ago

Last modified 9 years ago

T1 Head slider confusingly named

Reported by: bdezonia Owned by: bdezonia
Priority: major Milestone: imagej-2.0-alpha2
Component: Display API Version:
Severity: serious Keywords:
Cc: Blocked By:
Blocking:

Description

We are treating all IJ1 image stacks as labeled XYCZT. For the T1 Head stack it is obvious that it is an XYZ dataset. But it comes in as a 129 channel X by Y image (i.e. the slider says "Channel"). Do we want to modify the axis labelling code to default to XYZ when dimensions == 3?

Change History

comment:1 Changed 9 years ago by bdezonia

Giving the user a method for changing the names and orders of the axes would help alleviate this problem.

comment:2 Changed 9 years ago by bdezonia

Curtis says:

That T1 Head dataset does come in as a hyperstack with the correct labels, in IJ1. So, we can easily detect it, and translate properly. The problem is just with our ImageTranslator logic. Ultimately we should get rid of the imglib-ij dependency.

comment:3 Changed 9 years ago by curtis

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.