Ticket #394 (closed defect: duplicate)

Opened 8 years ago

Last modified 8 years ago

Unsigned 16 bit images display as all black

Reported by: bdezonia Owned by: gharris
Priority: major Milestone: imagej-2.0-alpha2
Component: UI Framework Version:
Severity: serious Keywords:
Cc: Blocked By:
Blocking:

Description

Opening the following samples (all of them 16-bit) displays images that are all black:

HeLa Cells, M51 Galaxy, Neuron, T1 Head

Change History

comment:1 Changed 8 years ago by bdezonia

Organ of Corti sample image also fails

comment:2 Changed 8 years ago by bdezonia

CT sample image displays as all gray. It is also 16 bit and thus may be related.

comment:3 Changed 8 years ago by bdezonia

Using the probe tool I've determined that all of these images have a small range of values within the maximum allowed range of 0-65535. It seems the image drawing code is not scaling the pixel values to a sensible display range. The code for handling and drawing BufferedImages in NavigableImagePanel is using BioFormats' AwtImageTools to create them and then drawing them with Java graphics code. Not sure where range scaling should be taking place. Is this something that should be done when color display and autoscaling is done for alpha 2?

comment:4 Changed 8 years ago by curtis

  • Owner changed from curtis to gharris
  • Status changed from new to assigned
  • Milestone changed from imagej-2.0-alpha1 to imagej-2.0-alpha2

Yes, color scaling is targeted for 2.0-alpha2. Changing milestone and assigning to Grant, who is in charge of this work.

comment:5 Changed 8 years ago by gharris

  • Status changed from assigned to closed
  • Resolution set to duplicate

Duplicate of #384

Note: See TracTickets for help on using tickets.