Ticket #337 (closed task: fixed)

Opened 8 years ago

Last modified 7 years ago

Find ImageJ bug that causes BioFormats ImporterTest to fail

Reported by: bdezonia Owned by: curtis
Priority: major Milestone: imagej-2.0.0
Component: SCIFIO Version:
Severity: serious Keywords:
Cc: Blocked By:
Blocking:

Description

At the hackathon Curtis found that BF's ImporterTest was failing for signed data. It worked in a earlier version of ImageJ but fails now. I have more detailed notes within this ticket. Find the bug and work with Wayne to get it resolved.

Change History

comment:1 Changed 8 years ago by bdezonia

  • Status changed from new to accepted

comment:2 Changed 8 years ago by bdezonia

Bioformats importerTest::testDatasetSwapDims int8 case is now failing. Not sure when it started to fail as test run infrequently. Broken with 1.44i & 1.44o and the latest BF plugin using fake files. Does it work on 1.43?? Fix this after hackathon. 1.43u worked & 144.k6 failed. Build them. Get Wayne’s Ant script. Give them to Curtis for the Nexus (:8081). Don’t build them all for Maven after all. Just ones I need for debugging. All Jars available for major versions at  http://rsb.info.nih.gov/ij/download/zips/

comment:3 Changed 8 years ago by bdezonia

  • Milestone changed from biweekly-2011: Feb-14 to Feb-25 to imagej-2.0-release

Since this only affects ImageJ 1.x and not in gui but just test push this until later. Make sure that this issue is not a problem with ImageJ 2.x when it is finally released.

comment:4 Changed 7 years ago by curtis

  • Owner changed from bdezonia to curtis

comment:5 Changed 7 years ago by curtis

  • Status changed from accepted to closed
  • Resolution set to fixed

The problem is not a bug in ImageJ, but rather in Bio-Formats, with its virtual stacks. Detailed posted at  ome:#7175. Closing this ticket in favor of that one.

Note: See TracTickets for help on using tickets.