Ticket #245 (closed defect: fixed)

Opened 9 years ago

Last modified 9 years ago

Improve Bio-Formats ITK plug-in handling of multichannel images

Reported by: hinerm Owned by: hinerm
Priority: major Milestone: biweekly-2010: Oct-18 to Oct-29
Component: SCIFIO Version:
Severity: serious Keywords:
Cc: Blocked By:
Blocking:

Description (last modified by hinerm) (diff)

As of  loci-software:r7050, code was added to the BFITK plug-in to change the order pixel data was passed back to Farsight, as Farsight seemed to require a different ordering of the data.

*.png and multichannel *.tiff files were tested and found to be opened correctly by Farsight.

However, now it seems that other image file types that were read correctly before are now reading channel information incorrectly. Confirmed: *.mov

Change History

comment:1 Changed 9 years ago by hinerm

  • Status changed from new to assigned

comment:2 Changed 9 years ago by hinerm

Additionally, when images with 5 or more channels are read via the BF-ITK plug-in, a null pointer exception occurs and the module seg faults.

comment:3 Changed 9 years ago by curtis

  • Description modified (diff)

comment:4 Changed 9 years ago by hinerm

  • Status changed from assigned to accepted

comment:5 Changed 9 years ago by hinerm

  • Description modified (diff)

comment:6 Changed 9 years ago by hinerm

  • Status changed from accepted to closed
  • Resolution set to fixed

after some investigation, it seems that the incorrect reading may be due to the *.mov file's channels being interleaved.

Changing the logic to only attempt reordering when the data is NOT interleaved seems to have resolved the issue for the sample file in question.

In addition to the logic change, I adjusted the debug statements to monitor isInterleaved in case this becomes an issue again in the future.

Note: See TracTickets for help on using tickets.