Ticket #2015 (closed defect: invalid)

Opened 6 years ago

Last modified 6 years ago

Menu does not work on Linux

Reported by: bdezonia Owned by: bdezonia
Priority: major Milestone: imagej2-b8-analysis
Component: UI Framework Version:
Severity: serious Keywords:
Cc: dscho Blocked By:
Blocking: #1457

Description

Running IJ2 from source 10-21-13 I cannot use the menu. IJ2 launches fine and app frame and menu look okay. But selecting a menu entry from the top of the frame has no effect (the menu is dead). And hovering over a toolbar button makes the menu disappear.

Change History

comment:1 Changed 6 years ago by bdezonia

  • Cc dscho added

dscho can you test on your system to see if you can replicate?

comment:2 Changed 6 years ago by bdezonia

Note I'm using OpenJDK here

comment:3 Changed 6 years ago by dscho

I just tried, and the toolbar does not disappear, nor is the menu unusable (Edit>Cut worked fine after selecting the ellipse tool and selecting an ellipsoidal region).

My java -version says this:

java version "1.6.0_27"
OpenJDK Runtime Environment (IcedTea6 1.12.6) (6b27-1.12.6-1ubuntu0.12.04.2)
OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)

comment:4 Changed 6 years ago by bdezonia

Thanks. I am using the exact same version of the OpenJDK. I'll futz some more.

comment:5 Changed 6 years ago by bdezonia

I can consistently replicate disappearing menu. Start IJ2 and do not mouse over any of the app frame or launch any commands. Then as first interaction move mouse from below app towards the hand icon. Menu disappears. Can you try this again dscho?

comment:6 Changed 6 years ago by bdezonia

Agh. Forgot to mention I am launching from within Eclipse (Kepler as of today).

comment:7 Changed 6 years ago by dscho

Note that I am launching from app/ImageJ.app after running bin/populate-app.sh -DskipTests.

It is quite possible that Kepler launches the JVM in a "funny" way.

comment:8 Changed 6 years ago by dscho

I now did what you asked me to: enter the mouse from the south, directly to the hand. Everything's groovy.

comment:9 Changed 6 years ago by bdezonia

Thanks dscho. Indeed if I launch ImageJ-linux64 via the app on the command line I cannot replicate.

comment:10 Changed 6 years ago by bdezonia

  • Status changed from new to closed
  • Resolution set to invalid
Note: See TracTickets for help on using tickets.