Ticket #1962 (closed enhancement: fixed)

Opened 6 years ago

Last modified 6 years ago

Investigate whether maven-failsafe-plugin is more appropriate than maven-invoker-plugin for our integration tests

Reported by: dscho Owned by: dscho
Priority: major Milestone: imagej2-b8-analysis
Component: Build System Version:
Severity: minor Keywords:
Cc: Blocked By:
Blocking: #1919

Description

We have a couple of integration tests in ij-legacy and ij-updater-core (needed because they start the JVM in a specific state). This developer found tutorials to use the invoker plugin to perform those tests, but recently, the question arose whether the failsafe plugin would be more appropriate to use.

While at it, investigate whether the updater tests could not be plain regression tests instead, creating fresh class loaders for the purpose of excluding certain classes from being found at first.

Change History

comment:1 Changed 6 years ago by dscho

  • Status changed from new to closed
  • Resolution set to fixed

This was not only addressed and answered in  https://github.com/imagej/imagej/commit/ff6ec66d, but the follow-up wish (turning all the invoker plugin based integration tests into failsafe based ones), too.

Note: See TracTickets for help on using tickets.