Ticket #1956 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Fix the Stable-Fiji job (updater not updated)

Reported by: dscho Owned by: dscho
Priority: major Milestone: imagej2-b8-analysis
Component: Updater Version:
Severity: serious Keywords:
Cc: Blocked By:
Blocking: #1347

Description

The recent Stable-Fiji job runs did not correctly update the updater. The reason is that despite calling the "pristine" update, obsolete versions of the updater itself were not removed, i.e. there were now ij-updater-core-2.0.0-beta4.jar, ij-updater-core-2.0.0-beta5.jar, ij-updater-core-2.0.0-beta7.jar and ij-updater-core-2.0.0-beta7.1.jar.

Change History

comment:1 Changed 6 years ago by dscho

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in  https://github.com/imagej/imagej/commit/a466d3081c60e3e92c3a348817cece408eae3a3c and  https://github.com/fiji/fiji/commit/5e60d97fdd45dc47cee1b1b3b1c6a2a9dc095813 (the latter is needed, too, because Stable-Fiji accesses the updater via  http://update.imagej.net/bootstrap.js which in turn feeds from Fix_Updater.js which feeds from Fiji's GitHub repository.

Note: See TracTickets for help on using tickets.