Ticket #1948 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Brightness/Contrast

Reported by: curtis Owned by: bdezonia
Priority: critical Milestone: imagej2-b8-analysis
Component: Analysis Plugins Version:
Severity: serious Keywords:
Cc: Blocked By:
Blocking: #1457

Description

With code on the current master branch, if you have a channel where the min and max data values are equal, the Brightness & Contrast plugin fails to initialize.

  • Press 'n' for new image
  • Set "Fill With" to "Zero"
  • Press 'c' for Brightness/Contrast

An exception is thrown:

Caused by: java.lang.IllegalArgumentException: invalid Real1dBinMapper: nonpositive data range specified
	at net.imglib2.histogram.Real1dBinMapper.<init>(Real1dBinMapper.java:87)
	at imagej.core.commands.display.interactive.BrightnessContrast.computeDataMinMax(BrightnessContrast.java:267)
	at imagej.core.commands.display.interactive.BrightnessContrast.viewChanged(BrightnessContrast.java:207)
	at imagej.core.commands.display.interactive.BrightnessContrast.initValues(BrightnessContrast.java:195)
	... 16 more

Change History

comment:1 Changed 6 years ago by bdezonia

  • Blocking 1457 added

comment:2 Changed 6 years ago by bdezonia

  • Status changed from new to closed
  • Resolution set to fixed

Fixed with commit 755f6cf0352fb59f643ccd163cbdfc58b9217bc9

Note: See TracTickets for help on using tickets.