Ticket #1912 (closed feature: duplicate)

Opened 7 years ago

Last modified 7 years ago

Redesign core I/O infrastructure [ndim-data]

Reported by: bdezonia Owned by: curtis
Priority: major Milestone: imagej2-b7-ndim-data
Component: I/O Version:
Severity: serious Keywords:
Cc: Blocked By: #47, #100, #215, #327, #649, #850, #860, #1013
Blocking:

Description (last modified by bdezonia) (diff)

ImageJ's current I/O infrastructure is largely built around the ij.io.FileInfo class. It generally assumes it is reading from a file, has many specialized considerations for TIFF and other formats, and is generally not modular in its design. There is also no real way to extend ImageJ's core I/O support other than to hack a special plugin called HandleExtraFileTypes, which has a number of limitations and disadvantages.
In contrast, the Bio-Formats library was designed with extensibility in mind. We propose a core ImageJ I/O package, similar to loci.formats, with IFormatReader- and IFormatWriter-like interfaces, to make it easier to extend ImageJ's file format support in a general way. Plugins implementing the correct interface would be automatically detected as new supported file types, and work out of the box with the ImageJ "Open" command.

Change History

comment:1 Changed 7 years ago by bdezonia

  • Blocked By 47 added

comment:2 Changed 7 years ago by bdezonia

  • Blocked By 100 added

comment:3 Changed 7 years ago by bdezonia

  • Blocked By 215 added

comment:4 Changed 7 years ago by bdezonia

  • Blocked By 327 added

comment:5 Changed 7 years ago by bdezonia

  • Blocked By 649 added

comment:6 Changed 7 years ago by bdezonia

  • Blocked By 850 added

comment:7 Changed 7 years ago by bdezonia

  • Blocked By 860 added

comment:8 Changed 7 years ago by bdezonia

  • Blocked By 1013 added

comment:9 Changed 7 years ago by bdezonia

  • Summary changed from Redesign core IO infrastructure [ndim-data] to Redesign core I/O infrastructure [ndim-data]

comment:10 Changed 7 years ago by bdezonia

  • Description modified (diff)

comment:11 Changed 7 years ago by bdezonia

  • Status changed from new to closed
  • Resolution set to fixed

All constituent tickets have been resolved for this beta. Closing feature.

comment:12 Changed 7 years ago by curtis

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:13 Changed 7 years ago by curtis

  • Status changed from reopened to closed
  • Resolution set to duplicate

NB: This ticket is a duplicate of #9.

Note: See TracTickets for help on using tickets.