Ticket #1908 (closed defect: moved)

Opened 6 years ago

Last modified 6 years ago

These images don't look right

Reported by: bdezonia Owned by: hinerm
Priority: major Milestone: imagej2-b8-analysis
Component: I/O Version:
Severity: serious Keywords:
Cc: Blocked By:
Blocking: #1457

Description

The following images do not appear correct in IJ2. In Fiji they look fine.

Attachments

4byteCompressedImageReaderBugFile.tif Download (108.1 KB) - added by bdezonia 6 years ago.
strike-uncompressed.tiff Download (200.4 KB) - added by bdezonia 6 years ago.

Change History

Changed 6 years ago by bdezonia

Changed 6 years ago by bdezonia

comment:1 Changed 6 years ago by hinerm

  • Blocking 1457 added; 1563 removed
  • Milestone changed from imagej2-b7-ndim-data to imagej2-b8-analysis

Currently, these images are opened similarly using SCIFIO as in FIJI with the Bio-Formats importer.

In both cases, they are opened as RGBA. Compositing the alpha channel makes the images look off.

IJ1 seems to be taking extra steps to process the alpha channel out, and opens this as an RGB image instead.

So we need to decide how to handle alpha channels.

Also, the color table for the 4th channel is blue in IJ2 but the Bio-Formats importer and IJ1 use white.

comment:2 Changed 6 years ago by bdezonia

Re: the 4th channel color table comment: note that IJ2's ColorTables default order is specified to be a different order than the Colors of a IJ1 CompositeImage. Thus the difference in the 4th channel between IJ2 and IJ1/Fiji. This appears to be by design.

comment:3 Changed 6 years ago by curtis

  • Status changed from new to closed
  • Resolution set to moved
Note: See TracTickets for help on using tickets.