Ticket #1902 (closed enhancement: wontfix)

Opened 6 years ago

Last modified 5 years ago

Investigate a better chat service

Reported by: dscho Owned by: dscho
Priority: major Milestone: imagej2-unscheduled
Component: Server Admin Version:
Severity: serious Keywords:
Cc: curtis Blocked By:
Blocking: #1711

Description

So far, we relied on IRC. The problem is that it is really unreliable (due to net splits which can lose important messages).

So let's investigate whether we can have chat rooms with Jabber, too.

Change History

comment:1 Changed 6 years ago by dscho

I played with this a bit:

  • added a new vhost jabber.imagej.net (alias conference.imagej.net) on dev
  • installed  OpenFire 3.8.2
  • followed the instructions from the  Candy Chat Wiki, in particular:
    • enabled Server>Server Settings>HTTP Binding
    • created imagej-devel@… via Group Chat>Room Administration>Create new room
    • enable the Client Control plugin to support autojoin via Plugins>Available Plugins
    • added a new group bookmark for all Users with Auto-Join enabled via Server>Client Management>Group Chat Bookmarks
  • cloned  Candy Chat
  • modified the Candy Chat example and put it into the root of  http://jabber.imagej.net/

To try, you need to edit your /etc/hosts to include a mapping from jabber.imagej.net to dev and direct your web browser to  http://jabber.imagej.net/.

Things to to now:

  • Decide whether we should use that room instead of IRC
  • Find where the logs are stored
  • Maybe add ourselves as registered users?
  • Link to that room from  http://fiji.sc/?

comment:2 Changed 6 years ago by dscho

Seems as if it does not handle Jabber accounts from other servers properly. Probably due to the lack of a properly signed certificate is my guess...

comment:3 Changed 6 years ago by bdezonia

  • Blocking 1711 added

comment:4 Changed 5 years ago by curtis

  • Status changed from new to closed
  • Resolution set to wontfix

Unfortunately, it is too time-consuming and difficult to get Jabber working properly. We do not have time; IRC is "good enough" for daily use.

Note: See TracTickets for help on using tickets.