Ticket #1883 (closed task: duplicate)

Opened 6 years ago

Last modified 6 years ago

Create a caching/stash service

Reported by: bdezonia Owned by: bdezonia
Priority: major Milestone: imagej2-b8-analysis
Component: Core Version:
Severity: serious Keywords:
Cc: Blocked By:
Blocking: #1923

Description

From a discussion with ctrueden:

Right now when we calc autoscale we use data min and max. But soon we'll want to calc autoscales from histograms, etc. It would be good to be able to cache these to minimize recalculation.

In general we should move away from how metadata is currently handled to instead have a general cache of metadata. This would allow us to extend the kinds of metadata we support. We could have a cache (or stash) service. The storing of metadata with ImgPluses will need to go away.

The stash service would allow one to say "save the histogram for the 7th plane of the 'zappydo' dataset". The stash keys would be built from Object ...'s. We would need to override stashkey's hashcode() and equals() methods. The hash could be an md5 hash of the sum of the constituent objects (but this might cause collisions so testing needed).

Alternatively our stash service could use existing libraries that already solve these problems. Search online.

Change History

comment:1 Changed 6 years ago by bdezonia

  • Blocking 1923 added; 1519 removed

comment:2 Changed 6 years ago by bdezonia

  • Status changed from new to closed
  • Resolution set to duplicate

Closing as duplicate of #1890.

Note: See TracTickets for help on using tickets.