Ticket #1853 (closed enhancement: fixed)

Opened 6 years ago

Last modified 6 years ago

Add a UI to start/stop shadowing files from another update site

Reported by: dscho Owned by: dscho
Priority: major Milestone: imagej2-b7-ndim-data
Component: Updater Version:
Severity: serious Keywords:
Cc: curtis Blocked By:
Blocking: #1901

Description

The idea about "shadowing" is that all update sites listed in a specific local db.xml.gz are ordered by priority: ImageJ, being the first one, has the least priority (because adding additional update sites indicates the user's desire to override ImageJ's files by the additional update site's if both sites serve the same .jar file).

The problem is that there is not yet a good UI to do that. The updater GUI should offer to start shadowing a file if it is locally-modified (or otherwise uploadable) and if the user can upload to an update site with higher priority. Likewise, if a file shadows a lower-priority site's file, there needs to be a way to stop shadowing it.

I guess the best way would be to add the context menu items "Shadow via <site>" and "Remove from <site>".

The plugin details should list exact information about shadowed files, too.

The updater GUI already disallows marking files for upload to/removal from different update sites; It should handle shadow/unshadow requests likewise.

To round it off, the command-line updater should get the same functionality; This should actually be the first thing to add, in conjunction with unit tests that use the command-line functionality to simplify the unit tests.

Change History

comment:1 Changed 6 years ago by dscho

  • Status changed from new to closed
  • Resolution set to fixed

This was fixed in ec605be7c66fd91133ea844abdc28079459b3df2.

comment:2 Changed 6 years ago by bdezonia

  • Blocking 1901 added; 1347 removed

comment:3 Changed 6 years ago by bdezonia

  • Milestone changed from imagej2-b8-analysis to imagej2-b7-ndim-data
Note: See TracTickets for help on using tickets.