Ticket #1754 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Reconcile dependency versions between Fiji and ImageJ2

Reported by: dscho Owned by: dscho
Priority: major Milestone: imagej2-b7-ndim-data
Component: Legacy Compatibility Version:
Severity: serious Keywords:
Cc: Blocked By:
Blocking: #1661

Description

For example, Fiji still requires jsch-0.1.42.jar but ImageJ2 requires jsch-0.1.49.jar. Somehow this seems to lead to instantiation problems when the LegacyService tries to load classes depending on jsch. We worked around this by disabling commands whose classes cannot be loaded. But the ideal solution would be to have identical dependency versions anyway.

Change History

comment:1 Changed 6 years ago by dscho

  • Status changed from new to closed
  • Resolution set to fixed

This was resolved in the commits leading up to Fiji's c8cc6ed7bf45b507b57a1d1ce9e7c742e5fd3f9b.

Note: See TracTickets for help on using tickets.