Ticket #1737 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Make the Fiji update site read-write again

Reported by: dscho Owned by: dscho
Priority: blocker Milestone: imagej2-b7-ndim-data
Component: Server Admin Version:
Severity: critical Keywords:
Cc: Blocked By: #1726, #1736, #1795
Blocking: #1040, #1115, #1729

Description

At the moment, the Fiji update site is read-only. This is due to a couple of reasons:

  • on pacific.mpi-cbg.de, we had a user group 'updaters' who were allowed to upload via SSH. This user group as well as the users do not exist on the new fiji.sc (which is fiji.imagej.net).
  • the new fiji.sc is behind a firewall, so we cannot rely on SSH. We can rely on WebDAV as soon as the WebDAV support is uploaded to the ImageJ update site (but it requires updating ij-updater-core, which requires updating ij-core, which requires uploading scijava-common...)
  • while WebDAV might allow us more fine-grained control (e.g. allowing nobody but Steffi to upload plugins/Stitching-*), the WebDAV account database needs to be populated and all existing uploaders need to be migrated to WebDAV.
  • as with SSH uploading support, we cannot rely on Fiji contributors to know what they're doing and figure out that they need to install ij-updater-<protocol> first. This has to be done automatically.
  • on pacific.mpi-cbg.de, we had an inotify-based script that committed all uploaded changes. It detected the author by looking at the owner of the just-uploaded file(s). With WebDAV, we have to come up with a different solution.

Change History

comment:1 Changed 6 years ago by dscho

  • Milestone changed from imagej2-unscheduled to imagej2-b7-ndim-data

comment:2 Changed 6 years ago by dscho

  • Blocked By 1795 added

(In #1795) The luts/ issue is blocking the upload of a current IJ2 revision to the update site, and hence a few other tickets which I just added.

comment:3 Changed 6 years ago by dscho

Next step happened: current IJ2 was uploaded to the update site.

comment:4 Changed 6 years ago by dscho

  • Blocking 1040 added

(In #1040) This ticket clearly require uploads to the Fiji update site to work again.

On the positive side, Fiji's source code is ready: 6423ca5d7d6a51e0bf79b2b2323f32d12fbd3210

comment:5 Changed 6 years ago by dscho

  • Priority changed from major to blocker
  • Severity changed from serious to critical

This is really a top priority. All Fiji developers depend on it, and there have already been complaints (although no serious offers to help... so the need cannot be all that serious).

comment:6 Changed 6 years ago by dscho

  • Blocking 1115 added

(In #1115) I tested current Fiji and it fails. The problem is that Retrotranslator is too old (and maybe other issues hidden by that one).

Yet another ticket blocked by fiji.sc/update not accepting uploads :-(

comment:7 Changed 6 years ago by dscho

I managed to set it up with WebDAV. A couple of UI issues with the WebDAV uploader that were not tested easily with the integration test cropped up.

Now the only issue is: how are uploaders supposed to set their passwords? We might be able to co-opt the Wiki database for this.

comment:8 Changed 6 years ago by dscho

Unfortunately, the format of the passwords is too different. So I will write a Wiki extension that has access to the WebDAV password database file.

comment:9 Changed 6 years ago by dscho

  • Status changed from new to closed
  • Resolution set to fixed

So I wrote that Wiki extension over the past hours. It's a pity that the people who pestered me will probably never acknowledge how much time and nerves they cost me, all without offering the slightest hint of assistance.

I sent out a mail to fiji-devel to describe the required steps:
 https://groups.google.com/forum/?fromgroups=#!topic/fiji-devel/Ly9YfWYBA3k

Note: See TracTickets for help on using tickets.