Ticket #1450 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

OptionsChannels allows last fg/bg colors to be edited

Reported by: bdezonia Owned by: bdezonia
Priority: major Milestone: imagej2-b4-plugins
Component: Plugin Framework Version:
Severity: serious Keywords:
Cc: Blocked By:
Blocking: #1171

Description

In the OptionsChannels dialog it has a couple colors that it displays for reference only and they are tagged with a MESSAGE modifier in the @Parameter notation. They used to just display the numeric RGB strings. However recently they began displaying the actual colors. However the color widget can be manipulated. These colors are not meant to be manipulated. They are recalculated every time just before launching a legacy plugin.

Change History

comment:1 Changed 7 years ago by curtis

  • Status changed from new to closed
  • Resolution set to fixed
  • Component changed from ij-plugins to ij-ext

This bug was caused by the message widget not being selected in favor of the color widget. The solution (bf159321) was to increase the priority of the message widgets: *any* input that is a message should be displayed using the message widget, regardless of its type.

comment:2 Changed 7 years ago by bdezonia

  • Status changed from closed to reopened
  • Resolution fixed deleted

Great but now the associated label is not displayed for the colors (run Options > Channels to see). And having an uneditable color rather than the rgb text description would be awesome but is perhaps asking for too much.

comment:3 Changed 7 years ago by curtis

  • Owner changed from curtis to bdezonia
  • Status changed from reopened to assigned

As discussed in chat earlier today, best solution will be to stop referencing lastBgColor and lastFgColor as @Parameters and instead manually persist their values by calling e.g. Prefs.get(OptionsChannels.class, "lastBgColor").

comment:4 Changed 7 years ago by bdezonia

  • Status changed from assigned to closed
  • Resolution set to fixed

The last fg/bg values are now only stored internally and never displayed.

comment:5 Changed 7 years ago by bdezonia

  • Blocking 1342 added

comment:6 Changed 7 years ago by bdezonia

  • Blocking 1171 added; 1342 removed
Note: See TracTickets for help on using tickets.