Ticket #1359 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

Updater: mark obsolete files for uninstall by default

Reported by: dscho Owned by: dscho
Priority: blocker Milestone: imagej2-b4-plugins
Component: Core Version:
Severity: fatal Keywords:
Cc: Blocked By:
Blocking: #1454

Description

At some stage, long ago, during the multiple update site changes, the Updater lost its ability to tell whether a file is obsolete. The reason is that the updater first reads information about files from the locally-cached database and then updates from the update sites. If the locally-cached record of the file has a current version, the update site was not able to override, since it could be *any* update site that has a current version.

This is a major blocker, as Fiji had loci_plugins.jar obsolete loci_tools.jar and without loci_tools.jar being correctly marked for uninstall, there would be an annoying warning everytime Fiji starts.

Change History

comment:1 Changed 7 years ago by dscho

  • Status changed from new to closed
  • Resolution set to fixed

This was fixed in 578b8a1fdfc1fbdb41721b27d6db42cf755b2bab. In the course of ensuring that this fix really fixes things, the UpdaterTest had to be modified to use the downloadIndexAndChecksum() method which was introduced after the initial UpdaterTest work; that was done in de60bdc35fe5547329ec080479a28903cb306a93 and in 744d43f7857d41098a81d8095e853cd91cef5ccc the regression test was added that proves that we fixed the issue.

comment:2 Changed 7 years ago by dscho

  • Blocking 1454 added

comment:3 Changed 7 years ago by dscho

  • Blocking 1347 removed
Note: See TracTickets for help on using tickets.