Ticket #1286 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

Changes in Image >> Properties not always reflected in results

Reported by: bdezonia Owned by: bdezonia
Priority: major Milestone: imagej2-b4-plugins
Component: Legacy Compatibility Version:
Severity: serious Keywords:
Cc: Blocked By:
Blocking: #1331

Description

Open Organ of Corti. Run Image >> Properties. Change Z to 5 and T to 3. Resulting image does not show any T axis. Z exists and runs from 1 to 5.

This may be another display axis not updating correctly bug too.

Change History

comment:1 Changed 7 years ago by bdezonia

  • Blocking 1331 added

comment:2 Changed 7 years ago by bdezonia

  • Status changed from new to closed
  • Resolution set to fixed

After recent changes to the legacy layer this bug appears to be fixed.

comment:3 Changed 7 years ago by bdezonia

  • Status changed from closed to reopened
  • Resolution fixed deleted

Reopening. It is still happening.

Previous debug effort showed that returned ImagePlus has Z & T and that the created display also has Z & T.

This sequence worked: make a new image, add a z axis of size 15, run Image Properties and set Z = 5, T = 3.

This sequence is failing: open Bat Cochlea renderings, run Image Properties and set Z = 4 and T = 9.

comment:4 Changed 7 years ago by bdezonia

  • Status changed from reopened to closed
  • Resolution set to fixed

Fixed with commit 17c72a9146d619b8bcdd590f93f95e3c0986bfd5

Note: See TracTickets for help on using tickets.