Ticket #1218 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

Sliders do not always update correctly

Reported by: bdezonia Owned by: bdezonia
Priority: major Milestone: imagej2-b3-headless
Component: Core Version:
Severity: serious Keywords:
Cc: Blocked By:
Blocking:

Description

Open Organ Of Corti. Reorder Data swapping the Z & C positions. Notice that the label shows the new order. The slider order does not change which is correct behavior. However moving the Z slider does not change the viewed data. This worked in beta2.

Note that there have been changes to how often redraws are done based on whether updateAxis() detects changes. And other dataset oriented events also less frequently generate update events. However moving the slider before reordering reacts correctly so this might be a red herring.

ReorderData used to be ReorderAxes. But the change was in name only and should not have caused any failures.

Change History

comment:1 Changed 7 years ago by bdezonia

One can also use AssignAxes and assign Organ Of Corti's Z axis to something like Spectra. The axis shows fine but moving it also has no effect.

comment:2 Changed 7 years ago by bdezonia

  • Summary changed from Reordering data does not update sliders correctly to Sliders do not always update correctly

comment:3 Changed 7 years ago by bdezonia

  • Status changed from new to closed
  • Resolution set to fixed

This bug caused by a commit in attempts to fix bug #1159. Fixed by commit 8781251be80b6c1c5bfc159ed1f2bc96e1ebb65c

Note: See TracTickets for help on using tickets.