Ticket #1213 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

Deleted overlays not removed from Overlay Manager

Reported by: bdezonia Owned by: bdezonia
Priority: major Milestone: imagej2-b3-headless
Component: Data Model Version:
Severity: serious Keywords:
Cc: Blocked By:
Blocking:

Description

Draw some overlays. Open the Overlay Manager. Now in the image window select an overlay and delete via a DEL key press. Overlay is not removed from Overlay Manager.

I recently changed the inheritance structure of the overlay classes. I think the issue is that the default overlay creations happen without a context. This context may be required to create OverlayDeletedEvents. Not sure though. Investigate.

Change History

comment:1 Changed 7 years ago by bdezonia

  • Status changed from new to closed
  • Resolution set to fixed

OverlayFigureView was not cleaning up correctly. Fixed with commit d7869d81ff80cbb5f3f6922ddfaf73e357a89b63

Note: See TracTickets for help on using tickets.