Ticket #1115 (closed defect: wontfix)

Opened 7 years ago

Last modified 5 years ago

Make IJ2 work on OS X Tiger

Reported by: bdezonia Owned by: dscho
Priority: major Milestone: imagej2-b10-compatibility
Component: Build System Version:
Severity: serious Keywords:
Cc: Blocked By: #1737
Blocking: #1348

Description

Herbie Gluender reported in the imagej mailing list that IJ2 beta1 does not run on Tiger. Johannes noted some issues with the launcher that he is working on for beta 2. Once those issues are ironed out we should test on Tiger if possible

Change History

comment:1 Changed 7 years ago by curtis

  • Milestone changed from imagej-2.0.0-beta3 to imagej-2.0.0-beta4

comment:2 Changed 7 years ago by dscho

  • Blocking 1348 added

comment:3 Changed 7 years ago by dscho

  • Milestone changed from imagej-2.0.0-beta4 to imagej-2.0.0-beta5

comment:4 Changed 6 years ago by dscho

The real problem, of course, is that we cannot use Java 6 on MacOSX 10.5.

comment:5 Changed 6 years ago by dscho

  • Blocked By 1737 added

I tested current Fiji and it fails. The problem is that Retrotranslator is too old (and maybe other issues hidden by that one).

Yet another ticket blocked by fiji.sc/update not accepting uploads :-(

comment:6 Changed 6 years ago by curtis

  • Summary changed from Test IJ2 on OS X Tiger to Make IJ2 work on OS X Tiger
  • Component changed from Testing to Build System
  • Milestone changed from imagej2-b7-ndim-data to imagej2-b10-compatibility

Support for Java 5, OS X Tiger, etc., using Retrotranslator, will not make it into beta7.

comment:7 Changed 6 years ago by dscho

It appears that I had to make some changes to the Retrotranslator in Fiji so it would kick in for Java 5 (and translate Java 6 as well as possible...) :-(

comment:8 Changed 5 years ago by curtis

  • Status changed from new to closed
  • Resolution set to wontfix

I am really not interested in supporting Tiger at this point...

Note: See TracTickets for help on using tickets.