Ticket #1107 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

Sometimes menu commands do not run

Reported by: bdezonia Owned by: curtis
Priority: major Milestone: imagej2-b3-headless
Component: Core Version:
Severity: serious Keywords:
Cc: G.Landini@… Blocked By:
Blocking: #1162

Description

Gabriel Landini reported in the imagej devel list:

Using linux. Some menu entries appear to require to be called twice to be run? For
example the Help>IJ2_Update never launches the first time it is called. There
are several of those. (like Options>Fonts)

Change History

comment:1 Changed 7 years ago by curtis

  • Blocking 1162 added

comment:2 Changed 7 years ago by bdezonia

I am unable to duplicate this behavior. I have tried the aforementioned menu commands and others using latest trunk build on Ubuntu 12.04. I see this was a beta1 bug. Can you try with beta2 or the latest trunk build?

comment:3 Changed 7 years ago by landinig

  • Status changed from new to closed
  • Resolution set to fixed

Yup, it seems to work fine now. I reported earlier that the preliminary testing was with openjdk, but now it seems to be OK with java 1.7.0 64 bit (although I have not tested this extensively).
Thanks to whoever who fixed this.

comment:4 Changed 7 years ago by curtis

We discovered a similar problem on Linux: clicking and holding the mouse button on a menu, then releasing on the desired menu item, does not work depending on whether the item in question is within the bounding box of the window frame. Johannes described the problem in more detail in a  recent mail to imagej-devel. The problem is present in 1.6.0-u24 but fixed in 1.6.0-u33.

Note: See TracTickets for help on using tickets.