Ticket #1106 (closed defect: worksforme)

Opened 7 years ago

Last modified 7 years ago

Sample images do not always load

Reported by: bdezonia Owned by: bdezonia
Priority: major Milestone: imagej2-b2-bugfixes
Component: Legacy Compatibility Version:
Severity: serious Keywords:
Cc: G.Landini@… Blocked By:
Blocking:

Description (last modified by bdezonia) (diff)

In the imagej devel mailing list Gabriel Landini reported:

Using linux. Not all sample images load successfully. Sometimes I can load one once but not again..

Change History

comment:1 Changed 7 years ago by bdezonia

Testing on Linux I cannot exactly reproduce. But if I open a bigger image (like T1 Head) and open blobs while it is still loading blobs will show up but the big image won't for some minutes. Gabriel, is this perhaps what you were seeing?

Last edited 7 years ago by bdezonia (previous) (diff)

comment:2 Changed 7 years ago by bdezonia

  • Description modified (diff)

comment:3 Changed 7 years ago by landinig

OK tried again under Java 7.0, and I can load all the sample images, so this might have been due to using OpenJDK earlier.
However it takes quite a long time to display them. For example the Nile Bend image takes about 5 sec to complete the progress bar, then another 30 sec to display the image (on a quadcore machine). That is about twice what it takes in IJ1.
Maybe this is related to the slow GUI I mentioned elsewhere?

comment:4 Changed 7 years ago by bdezonia

Just to note I used OpenJDK on Linux and do not have sample load issues.

comment:5 Changed 7 years ago by bdezonia

  • Status changed from new to closed
  • Resolution set to worksforme

See #1155 for slow load issues
See #1154 for problems loading two images simultaneously
The rest of this ticket is being closed as can't duplicate

Last edited 7 years ago by bdezonia (previous) (diff)

comment:6 Changed 7 years ago by bdezonia

  • Milestone changed from imagej-2.0.0-beta3 to imagej-2.0.0-beta2
Note: See TracTickets for help on using tickets.