Ticket #1104 (closed defect: fixed)

Opened 7 years ago

Last modified 5 years ago

Cannot open XML files for TrakEM2

Reported by: bdezonia Owned by: bdezonia
Priority: major Milestone: imagej2-b10-compatibility
Component: Other Version:
Severity: serious Keywords:
Cc: sapristi@… Blocked By:
Blocking: #1458

Description

In the imagej devel mailing list Albert Cardona reported

Can't open XML files for TrakEM2. One gets an error dialog complaining about Quicktime.

Change History

comment:1 Changed 7 years ago by bdezonia

Albert, can you be more specific? What command are you using? Opening an XML file from within TrakEM2 on top of IJ2? Can you layout the exact steps to recreating you problem? Thanks.

comment:2 Changed 7 years ago by bdezonia

  • Milestone changed from imagej-2.0.0-beta3 to imagej-2.0.0-beta4

comment:3 Changed 7 years ago by bdezonia

  • Status changed from new to closed
  • Resolution set to invalid

I have heard nothing back. Albert, I am closing this ticket as invalid. If you have more details then reopen this ticket and provide them. Thanks.

comment:4 Changed 7 years ago by bdezonia

  • Status changed from closed to reopened
  • Resolution invalid deleted

Albert writes:

create trakem2 project, push s to save it into an xml file, them run imagej2 file open. You will see that it does not open as TrakEM2, but the LOCI dialog opens.

comment:5 Changed 7 years ago by bdezonia

  • Blocking 1339 added

comment:6 Changed 7 years ago by bdezonia

For further instructions in reproducing this issue read the following thread from the imagej dev mail list:

 http://imagej.net/pipermail/imagej-devel/2012-July/001089.html

comment:7 Changed 7 years ago by curtis

See also  this thread on the imagej-devel mailing list.

comment:8 Changed 6 years ago by bdezonia

  • Blocking 1458 added; 1339 removed
  • Milestone changed from imagej-2.0.0-beta4 to imagej-2.0.0-beta5

comment:9 Changed 6 years ago by curtis

  • Milestone changed from imagej-2.0.0-beta6 to imagej-2.0.0-beta7

comment:10 Changed 6 years ago by curtis

  • Milestone changed from imagej-2.0.0-beta7 to imagej-2.0.0-beta9

comment:11 Changed 5 years ago by curtis

  • Status changed from reopened to closed
  • Resolution set to fixed

The IOService framework for ImageJ2 is complete and available. File > Open uses this framework, looking for available IOPlugins. Some future version of TrakEM2 could provide such a plugin to make File > Open work in ImageJ2 UIs. But actually, the issue will be mostly moot due to the fact that for now, ImageJ2 is going to stick with the IJ1 UI. It will (optionally) override the behavior of File > Open to use IOPlugins first -- which includes use of SCIFIO and hence better TIFF support as well as OME-TIFF and other formats extensible via SCIFIO plugins. But it will also fall back to IJ1's approach if none of IJ2's IOPlugins are appropriate, which should be the case for TrakEM2 XML files.

I am closing this as "fixed" since TrakEM2 XML files should work with IJ2 while in its default IJ1 UI mode, and there now exists a mechanism to make TrakEM2 XML files work in "pure IJ2" as well.

Note: See TracTickets for help on using tickets.