Ticket #1102 (closed defect: wontfix)

Opened 8 years ago

Last modified 8 years ago

ROIs can be drawn outside image

Reported by: bdezonia Owned by: curtis
Priority: major Milestone: imagej2-b3-headless
Component: Other Version:
Severity: serious Keywords:
Cc: G.Landini@… Blocked By:
Blocking:

Description

In the imagej devel mailing list Gabriel Landini reported the following:

I noted that one can put ROIs in that non-image region of the window. That must be a bug I guess?

Change History

comment:1 Changed 8 years ago by bdezonia

Curtis, please verify that this is not by design.

comment:2 Changed 8 years ago by curtis

  • Status changed from new to closed
  • Resolution set to wontfix

The ability to draw ROIs outside the image is actually by design.

The rationale is that ImageJ2 displays will allow visualization of more than one dataset simultaneously. For example, you may have a mosaic of image tiles, all displayed in the same image window, similar to TrakEM2.

In such a case, it makes sense to be able to draw a ROI either: A) specific to particular dataset; or B) in the display's aggregrate coordinate space, potentially across multiple datasets. That could include the ROI spanning empty space between registered tiles.

So in general, ROIs much not be limited to the dataset only.

For more information, see ticket #660, which discusses the addition of a CompositeData object that will allow a tree structure of data objects. In this way, overlays (i.e., ROIs) will be able to be associated with data at any layer of the tree, to avoid ambiguity regarding what they are annotating.

Note: See TracTickets for help on using tickets.