Ticket #1058 (closed defect: wontfix)

Opened 8 years ago

Last modified 8 years ago

Tool delegation issues

Reported by: bdezonia Owned by: dscho
Priority: major Milestone: imagej2-b1-initial
Component: Tools Version:
Severity: serious Keywords:
Cc: Blocked By:
Blocking:

Description

There are a couple of issues that the probe readout is having and I think they are related to tool delegation.

1) If you move the probe out of an image the last status event persists. If you do so very slowly it gets cleared. Putting print statements in PixelProbe show that the tool is not active when it could be. I have put in as much code as possible into PixelProbe to null out the status event area to no avail.

2) when moving the pixel probe slowly near the right and left edges you can see its inaccurate as to when it should quit being active. On the left you never get a clearing of the status event area. On the right you do for a couple pixels. Note that in this case the clearing seems to happen too early as there is still room on the right of the image. This may be a cursor drawing error rather than a delegation error. But delegation errors seem possible on the left edge.

Change History

comment:1 Changed 8 years ago by dscho

  • Status changed from new to closed
  • Resolution set to wontfix

When inspecting scientific images, I often find myself switching to other applications still wanting to see the the status bar information.

Therefore I'll mark this as a WontFix...

Note: See TracTickets for help on using tickets.