Ticket #1025 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

Lin & Win: When opening the Blobs example, the MenuBar is cramped and the scrollbars are shown

Reported by: dscho Owned by: dscho
Priority: major Milestone: imagej2-b1-initial
Component: Display API Version:
Severity: serious Keywords:
Cc: Blocked By:
Blocking:

Description

On MacOSX, all looks fine, but when opening the Blobs sample on Linux or Windows, the window seems not large enough by default: the scrollbars are visible and the menu bar looks awfully squashed.

I chased this bug for the past few hours (in the vain hope to verse myself in JHotDraw think, but it was not a JHotDraw issue after all). Turns out that the problem is that the content pane was not repacked after adding the menu bar -- not a problem on MacOSX since the menu bar is not a part of the window there.

So, this ticket is just for the record, I will close it in a second.

Change History

comment:1 Changed 7 years ago by dscho

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.