Ticket #1022 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

Remove the Selection Tool

Reported by: dscho Owned by: dscho
Priority: major Milestone: imagej2-b1-initial
Component: Display API Version:
Severity: serious Keywords:
Cc: Blocked By:
Blocking: #878

Description

ImageJ 1.* does not have a selection tool: when the user hovers drags a handle, the corresponding selection is modified, when the user clicks & drags somewhere else in the selection, the whole selection is moved.

Add a DelegationTool that uses JHotDraw to detect when the mouse cursor is hovering above a selection or selection handle and transparently hands off to the SelectionTool in that case; otherwise, a new selection is added or replaces the complete selection, depending whether the Shift key is pressed (add) or not (replace).

There is a third mode in ImageJ 1.*, unfortunately: holding down the Alt key when selecting something removes that part from the existing selection. The problem is that this can modify the type of the selection: a rectangle from which a part is been removed is very unlikely to be a rectangle still. See #878 for details.

Change History

comment:1 Changed 7 years ago by dscho

  • Component changed from other to ij-display

comment:2 Changed 7 years ago by dscho

  • Status changed from new to accepted

comment:3 Changed 7 years ago by dscho

The first part of this is now committed.

The Alt key handling needs #878 to be addressed first, though.

comment:4 Changed 7 years ago by curtis

  • Blocked By 878 removed

comment:4 Changed 7 years ago by curtis

  • Status changed from accepted to closed
  • Resolution set to fixed
  • Blocking 878 added

Selection tool is successfully eliminated. Alt key will not work until subtracting ROIs works (see ticket #878). But there is nothing left to do for this specific ticket.

Note: See TracTickets for help on using tickets.